查看: 6877|回复: 0

高版本1.6.* Arduino IDE不兼容SPI库的应用

[复制链接]
本帖最后由 touchfree 于 2015-6-3 18:23 编辑

针对windows用户,Arduino 官方目前最新版的arduino上位机软件版本为1.6.*, 改版本针对SPI库的兼容性不是很好,因此建议使用版本1.0.6.

但也不是没有解决办法:

1. 下一个1.0.6的安装包,安装之后找到SPI库文件,复制出来。//或者在附件中下载。

2. 找到1.6.*的安装文件夹,将 1中的文件粘贴到 库中(注意不是加载库时候用的 document/文档 文件夹下的库,否则无效),如图所示:

QQ截图20150603173023.png


3. 测试,本人用wido来测试。成功在1.6.4下编译上传,连上wifi。如图所示:

QQ截图20150603172020.png

欢迎建议和反馈!

SPI.zip

5.77 KB, 下载次数: 451, 下载积分: 创造力 -1

1.0.6中的spi库

您需要登录后才可以回帖 登录 | 立即注册

本版积分规则

为本项目制作心愿单
购买心愿单
心愿单 编辑
wifi气象站

硬件清单

btnicon
我也要做!
点击进入购买页面
上海智位机器人股份有限公司 沪ICP备09038501号-4

© 2013-2019 Comsenz Inc. Powered by Discuz! X3.4 Licensed

mail