5328浏览
查看: 5328|回复: 9

[已解决] bluno+bluno扩展板没能连接上

[复制链接]
bluno扩展板终于到了,马上测试~
bluno+bluno扩展板+iphone5 ios7.0.6已安装玩转布鲁诺,上传BLUNO.ino和添加PlainProtocol.zip之后手机可以搜索到设备,但是点了之后就没显示connected,温度湿度都没有显示,主板上的红灯(link)常亮,TX/RX两个灯同时不停闪烁,手机一直没法控制bluno扩展板,请问怎样解决?

mickey  NPC

发表于 2014-3-27 17:19:53

检查一下Bluno主板上的AT开关是否拨到NORM端?
回复

使用道具 举报

hikarumk2  中级技师
 楼主|

发表于 2014-3-27 21:40:37

mickey 发表于 2014-3-27 17:19
检查一下Bluno主板上的AT开关是否拨到NORM端?

是的,已经调至NORM端,但是还是连接不上。
回复

使用道具 举报

Angelo  初级技匠

发表于 2014-3-28 11:11:44

请问,APP上面的情况是什么样子的?
是灰色的,还是正常的颜色?
如果“红灯(link)常亮,TX/RX两个灯同时不停闪烁”
那么数据通信应该是正常进行的~
回复

使用道具 举报

hikarumk2  中级技师
 楼主|

发表于 2014-3-28 21:28:25

Angelo 发表于 2014-3-28 11:11
请问,APP上面的情况是什么样子的?
是灰色的,还是正常的颜色?
如果“红灯(link)常亮,TX/RX两个灯同时 ...

app上是显示“搜索”按进去可以看到主板的名字“XXX1.6”选择之后回到app的主画面,主板TX/RX两个灯开始同时不停闪烁,但是主画面还是显示“搜索”而不是connected
回复

使用道具 举报

Angelo  初级技匠

发表于 2014-3-31 11:55:24

哦,新版的APP软件就是这样的~~
主画面还是显示“搜索”而不是connected,同时如果再打开搜索,已经连上的设备就不会在列表中出现了。
一旦你连接上了BLUNO,
屏幕就会从非激活(灰色)状态,变成激活状态。
WIKI还没有来得及改~
回复

使用道具 举报

hikarumk2  中级技师
 楼主|

发表于 2014-3-31 18:02:01

Angelo 发表于 2014-3-31 11:55
哦,新版的APP软件就是这样的~~
主画面还是显示“搜索”而不是connected,同时如果再打开搜索,已经连上的 ...

是从灰色变成彩色,然后控制LED灯那里可以按成on,然后调颜色,但是扩展板上的灯不亮,iphone上也没有显示温度。要不我把主板和扩展板一起寄回去给你们测试一下?
回复

使用道具 举报

Angelo  初级技匠

发表于 2014-4-1 09:48:44

Arduino上面的程序用的是哪一个版本,这种情况的话,我感觉可能是Arduino端上传的代码有点问题。
或者尝试一下使用AT指令(AT+SETTING=DEFAULT)初始化一下蓝牙模块~
回复

使用道具 举报

Holiday  初级技匠

发表于 2014-4-1 12:02:15

弱弱地插一句:会不会是。。。。手机蓝牙没开。。。。
回复

使用道具 举报

Holiday  初级技匠

发表于 2014-4-1 12:04:03

Holiday 发表于 2014-4-1 12:02
弱弱地插一句:会不会是。。。。手机蓝牙没开。。。。

好吧,蓝牙开过了。。。。看漏了。。。不过这个APP在IOS上好像要点下什么确定表示授权才能使用的
回复

使用道具 举报

高级模式
B Color Image Link Quote Code Smilies |上传

本版积分规则

为本项目制作心愿单
购买心愿单
心愿单 编辑
[[wsData.name]]

硬件清单

  • [[d.name]]
btnicon
我也要做!
点击进入购买页面
上海智位机器人股份有限公司 沪ICP备09038501号-4

© 2013-2024 Comsenz Inc. Powered by Discuz! X3.4 Licensed

mail